Text in Selection tabs disappeared

bentITdude
Posts: 8
Joined: Tue Jul 11, 2017 6:40 pm

Text in Selection tabs disappeared

Postby bentITdude » Thu Sep 28, 2017 6:24 pm

Hello,

This seems like a super silly thing, but I can't seem to figure out how to get the text to show up in the selection tab area. Image

https://imgur.com/ANlrpF7

I've tried re-installing 6.16 - and then went up to 6.5 hoping that would do it. But no luck.

Any ideas?

Thanks!

JClarke
Posts: 20
Joined: Mon Sep 11, 2017 6:12 pm

Re: Text in Selection tabs disappeared

Postby JClarke » Mon Oct 02, 2017 4:32 pm

Seeing this as well, Max 2018.3, Vray 3.6, RPM 6.5

Not surprisingly, the text is actually there, both in the blue tab and the unselected ones also, just the colors are really really hard to read. If I bring a screenshot in to photoshop i can color correct to make the text appear, I'm just not sure if the RPM color settings are something we have access to anywhere? Not sure if it's pulling settings from Max color preferences or an RPM ini perhaps? Lots of the links on the old forum are giving me errors when I try to view threads.

bentITdude
Posts: 8
Joined: Tue Jul 11, 2017 6:40 pm

Re: Text in Selection tabs disappeared

Postby bentITdude » Mon Oct 02, 2017 5:23 pm

That's what I was wondering too.. like if there was a text color setting that was pulling from an .ini or a config file somewhere...

I figured it has got to be pulling that information from somewhere.

The weird thing is that I've updated RPM on two other machines, and they haven't had the same issue. I guess I can try changing the Windows theme and see if it has any effect.

admin
Site Admin
Posts: 133
Joined: Mon Jun 19, 2017 4:08 pm

Re: Text in Selection tabs disappeared

Postby admin » Tue Oct 03, 2017 12:45 pm

Hi

There is an .ini file that controls the colours - it's a file called

RPMUIColors.ini

in the scripts/RPManager directory.

When this file doesn't exist, RPM will create it - so you can try renaming it (or deleting) and see if that sorts it out. It looks at the current UI colours and tries to figure out something that is visible and works with the current settings (ie dark, light) but it doesn't always get it right.

What is in the file is a little cryptic and right now I don't know which is which but I'm very sure the colours in the tab are controlled, but you might want to edit all the colour values at once to confirm that the tabs are indeed updated, but mine looks like this:


[UIColors]
AXbg=(color 102 102 102 382.5)
AXtext=(color 255 255 255)
disabledRMPasses=(color 68 68 68)
localNet=(color 68 68 68)
visSetGrey=(color 128 128 128)
visSetAssign=(color 68 68 68)
visSetSpecial=(color 85 204 238)
contrastOne=(color 187 187 187)
contrastTwo=(color 187 187 60)
contrastThree=(color 187 60 187)
contrastFour=(color 60 187 187)
contrastFive=(color 170 170 170)
contrastSix=(color 187 187 60)
contrastSeven=(color 60 187 187)
contrastEight=(color 22 22 22)


I'm also quite sure that you don't need to restart 3dsmax for the colours to be picked up, but I could be wrong - I'm currently travelling and won't be back where I can easily test this for a couple more days.

cheers,
grant

JClarke
Posts: 20
Joined: Mon Sep 11, 2017 6:12 pm

Re: Text in Selection tabs disappeared

Postby JClarke » Tue Oct 03, 2017 3:53 pm

'Magically' it started working today, seemingly without me doing anything.

After reading Grant's response, I bet I know what happened. Yesterday I wasn't running Max as Admin, so when I ran RPM it wasn't able to automatically create the ini file due to UAC permissions and whatnot. Today I've been setting up other scripts that required running as admin, and I tested RPM again and it worked. I closed max and reopened not as admin, text is all fine.

bentITdude
Posts: 8
Joined: Tue Jul 11, 2017 6:40 pm

Re: Text in Selection tabs disappeared

Postby bentITdude » Tue Oct 03, 2017 4:39 pm

Copying and pasting the code from your .ini file worked like a charm, Grant. Thanks a ton!

I did try running as Admin, but that didn't do it by itself for me. Now I can read stuff!!!

Thanks again!

bentITdude
Posts: 8
Joined: Tue Jul 11, 2017 6:40 pm

Re: Text in Selection tabs disappeared

Postby bentITdude » Wed May 22, 2019 9:32 pm

I thought I'd update to let you know another way that it's fixed.

This is especially true in Windows 10 - but you have to allow modify permissions in the plugins and the scripts folder of your 3ds Max install.

For the studio - just allowing Domain Users worked for me. If you're not on active directory you probably have to allow each individual user.


Return to “Bugs”

Who is online

Users browsing this forum: No registered users and 1 guest

cron